Mais

Exibição de imagem raster em um MapServer WMS

Exibição de imagem raster em um MapServer WMS


Estou tentando exibir uma imagem raster usando MapServer, mas não está exibindo nada, a página está em branco

Meu código de arquivo de mapa é:

NOME DO MAPA "ny_pop" SHAPEPATH "C:  ms4w  apps  webgis  mpgaps" EXTENSÃO 8240841.450745 2400319.900386 9218007.463612 3107183.406947 TAMANHO 450 500 STATUS DESLIGADO DEBUG ON IMAGETYPE "png" png "PROJEÇÃO" png "png" PROJEÇÃO do png "eps" png13 AGUT "E31663612 3107183.406947 SIZE 450 500 STATUS DESLIGADO" png "NOME DE FORMA DE IMAGEM 900" eps 91363612 "png" eps AGUT "= 9009 Png" PROJ. / PNG MIMETYPE "image / png" IMAGEMODE RGB EXTENSION "png" FORMATOPTION "GAMMA = 0.75" END WEB METADATA "wms_title" "WMS Pop Tif" "wms_onlineresource" "http: // localhost: 8085 / cgi-bin / mapserv.exe ? mode = map & map = C:  ms4w  apps  webgis  mpgaps  raster.map "" wms_enable_request "" GetMap GetFeatureInfo GetCapabilities "END END ############# LAYER NAME" ny_pop "DATA" 094_056_d_mar26_2012_ mar-08.tif "STATUS OFF TYPE RASTER METADATA" wms_title "" WMS NY Raster "" wms_srs "" EPSG: 900913 "FIM FIM #############

FIM

O caminho dos dados é C: ms4w apps webgis mpgaps


O problema parece ser a seguinte linha:

"wms_onlineresource" "http: // localhost: 8085 / cgi-bin / mapserv.exe? mode = map & map = C: ms4w apps webgis mpgaps raster.map"

Mude para:

"wms_onlineresource" "http: // localhost: 8085 / cgi-bin / mapserv.exe? map = C: ms4w apps webgis mpgaps raster.map"

Omode = map &opção não é correta para um WMS


Assista o vídeo: Videotutorial de MapServer