Mais

Suporte do navegador para ArcGIS API para JavaScript?

Suporte do navegador para ArcGIS API para JavaScript?


Alguém pode me dar informações ou uma boa indicação sobre o suporte à versão do navegador no ESRI ArcGIS JavaScript API v2.4?

Não consigo encontrar muito em sua documentação além de mudanças no suporte para navegadores específicos em cada versão da API "O que há de novo".

Eu vi que a API usa SVG para alguma renderização do lado do cliente, o que deve afetar o suporte entre navegadores. Além disso, imagino que haja algumas peculiaridades para as versões mais antigas de todos os principais navegadores.

Provavelmente estarei direcionando versões recentes de navegadores baseados em desktop em meu próximo projeto, mas gostaria de saber quaisquer problemas com antecedência, pois provavelmente estamos indo com JavaScript em vez de Silverlight especificamente para o suporte de plataforma mais amplo.


Eu trabalho na equipe da API JS e, honestamente, poderíamos fazer um trabalho melhor ao documentar isso. Dito isso, oferecemos suporte aos navegadores compatíveis com a versão do dojo que estamos usando. As últimas versões do ArcGIS JS API (2.3 e 2.4) usam dojo 1.6.1. As notas de versão do dojo 1.6 listam os navegadores suportados: http://docs.dojocampus.org/releasenotes/1.6

A única ressalva é que atualmente não fazemos muito esforço para oferecer suporte ao IE6.

Há também a lista de navegadores com suporte para a versão 2.0 das APIs da Web: http://resources.arcgis.com/content/webapis/2.0/system-requirements A única grande atualização para isso é que oferecemos suporte ao IE9 na v2.3 e além.

Com relação ao SVG, este é um dos grandes motivos pelos quais usamos o dojo. O módulo gfx do Dojo abstrai as diferenças do navegador para que possamos usar SVG em navegadores que o suportam, mas recorrer a tecnologias alternativas (VML para IE <9; Canvas para Android) quando necessário.


Assista o vídeo: Arcgis + PostgreSQL - Integração